/ Home \ \ Subjects /

Subject: PHP5.x.x "Warning: Cannot load module 'SQLite' because required module 'pdo' ...

24/10/2008 05:19 Xene:
"Cannot load module 'SQLite' because required module 'pdo' is not loaded"

I haven't been able to figure out why I can't get the php to work proplery. I've tried using manual install as well as msi (apache 2.2.x) then directing smallsrv to the php-cgi.exe after editing the configurations

display_startup_errors = On
arg_separator.input = "&"
variables_order = "GPECS"
register_globals = On
magic_quotes_runtime = On
enable_dl = On
cgi.force_redirect = 0
force_redirect = 0
The line ;pfpro.defaultport = 443 must be comented

as was told, however it continues to return this error or if this error isn't returned the page loads scrambled. I also cannot find "force_redirect = 0
The line ;pfpro.defaultport = 443 must be comented" in the php.ini file (php 5.x.x latest). I've tried commenting/uncommenting both sqlite and pdo but to no avail.

Does anyone have a sure fire way of getting the php to work with smallsrv? (the same php works with the apache fine but apache just doesn't have the features smallsrv does..) is the page I'm trying to get it working on for a small forum for some friends, any help would be greatly appreciated.
24/10/2008 11:39 Xene:
The solution found was to use php-cgi.exe and edit the above things (if some are missing from your ini that's alright) copy the php.ini to the windows folder and copy all non php-x files inside the C:\php\ to your C:\windows\system32

I used to install the php initially then changed minor things. The current .dll's un commented are as follows php_mysql.dll php_mysqli.dll and php_openssl.dll

and it appears to now work with smallsrv.
25/10/2008 14:32 Max:
Copping files to SYSTEM32 it is effective, but not very good solution. Probably add path to PHP to system PATH environment variable is enough. (Right button on "My computer", then Properties, then "Environment" on one tabs )

If you would like to use php5isapi.dll instead php-cgi.exe, in some version of PHP, php5isapi.dll must be in the same directory that php5ts.dll

Also you may try to add registry key:

21/03/2009 00:41 AnrDaemon:
Cannot load module 'SQLite' because required module 'pdo' is not loaded

This has it all in front of you, dunno why you can't see it.
You must have PDO module loaded before you try to load SQLite module.
Check the loading order in INI file.

User: Password: New user:   Save password: