/ Home \ \ Subjects /

Subject: smallsrv for linux

14/04/2010 14:49 Rimifon:
Hi Max
php is not support in shttplnx?
and run shttplnx need wine?
and IPv6 in smallsrv return "2001:0:53AA:64C:0:5EDB:AC21:E50-"Cstandard is "2001:0:53aa:64c:0:5edb:ac21:e50"
14/04/2010 20:33 Max:
PHP as any executable script is supported. In version up to 3.05.86 it is require to add shell direction string as first line of PHP file:
#!/usr/local/bin/php-cgi -c /etc/php.ini
(as any shell in *NIX)
In version 3.05.87 has been added special parameter to direct command string for php-cgi, like in Windows version. With this parameter PHP scripts still must be have "executable for all" mode, but may not content shell direction line.

httpd.exe in shttplnx.tgz it is native ELF Linux application. Not need wine, and not required libraries exclude standart libc.

15/04/2010 19:33 Rimifon:
The username is "rimifon" and the password is "******".
rimifon @ debian: ~ $. / httpd.exe
-sh:. / httpd.exe: No such file or directory

Time to run in Ubuntu is the same error, try to install wine1.2, the program correctly.
But Debian's text mode can not be installed wine.
15/04/2010 21:14 Rimifon:
sudo apt-get install ia32-libs
httpd.exe is running!
15/04/2010 22:03 Rimifon:
but php is not work:
Error.Script return nothing ..
info.php is 755.
info2.php, test.sht were 644

#!/usr/local/bin/php5-cgi -c /etc/php5/cgi/php.ini
15/04/2010 22:54 Max:
httpd.exe is 32-bit application.
To run application from current directory that not in PATH you must type

To option php try to run the script without the server. Type ./info.php and check output.

May be /usr/local/bin/php5-cgi must be directed in /etc/shells or php.ini require some options.

16/04/2010 06:11 Rimifon:
Thanks,that's run correctly. ..

16/04/2010 07:14 Rimifon:
Thanks,that's run correctly. ..


User: Password: New user:   Save password: